Chat Support Temporarily Unavailable
Incident Report for Tallie
Resolved
Chat support is back online! Thank you for your patience.
Posted Feb 15, 2018 - 12:58 PST
Identified
Our third party chat support tool is currently experiencing connection issues, resulting in chat messages not coming through to our Product Experts Team. Please direct all support questions to support@usetallie.com and 888-874-1118 x2. There's no degradation in Tallie performance.
Posted Feb 15, 2018 - 12:09 PST