Error Processing Billing Information
Incident Report for Tallie
Resolved
Our payment processing system is back up and Tallie is processing billing information normally now.
Posted about 1 month ago. Jul 10, 2019 - 16:16 PDT
Monitoring
Our third-party payment processing system is currently experiencing issues. If you receive an error while entering billing information in Tallie, please try again later. We will provide updates here when the payment processing system is back up. Tallie product functionalities are not affected.
Posted about 1 month ago. Jul 10, 2019 - 15:48 PDT