Outage - October 9, 2023
Incident Report for Tallie
Resolved
The outage has been resolved.
Posted Oct 09, 2023 - 13:13 PDT
Investigating
We are receiving reports from multiple customers that they are unable to access Tallie. We are currently investigating this issue.
Posted Oct 09, 2023 - 11:34 PDT
This incident affected: Tallie Web App.