Support Site is Unaccessible
Incident Report for Tallie
Resolved
Our support site and help desk are fully functional now. Thanks for your patience!
Posted Sep 16, 2019 - 13:36 PDT
Monitoring
Our support site, help.tallie.com, is currently unaccessible due to a service outage impacting our third-party help desk application. While we continue to monitor their status, our support team can be reached by phone at 888-874-1118 ext. 2. We will update this page as soon as our help site becomes available.
Posted Sep 16, 2019 - 11:24 PDT
This incident affected: Support Site.