No PEX Service Disruption at This Time
Incident Report for Tallie
Resolved
We have made some changes to ensure continued support for our PEX card integration.
Posted 8 months ago. Jan 11, 2019 - 09:44 PST
Identified
We apologize for any concerns or confusion some customers may have experienced from a technical email sent by the PEX team. At this time there is no service disruption and we are working with the PEX team to continue to offer support for our shared customers.
Posted 9 months ago. Dec 11, 2018 - 10:03 PST